Connection dialog box greyed out in editor play mode until restart

Description, details and error message(s)

After successfully connecting using the connection dialog box, occasionally the connect button is disabled upon entering play mode making it impossible to connect. Only restarting the Unity Editor seems to fix it until the issue reoccurs.

No obvious errors in the console.

I am running a local replication server (world)

Expected behaviour

Connection dialog box to load correctly each time in play mode with connect button active (blue)


Screenshot 2023-06-28 181847

How to reproduce



  1. Enter play mode
  2. Connection dialog loads correctly with Connect button active
  3. Connect (successfully)
  4. Stop editor play mode
  5. Restart editor play mode
  6. Connection dialog greyed out, Connect button disabled


SDK: 0.10.15, Engine: 0.59.0
Unity: 2022.3.2f1
OS/Platform: Windows 10

Hey @_talkietoaster, thanks for the very detailed report!
Let’s see. I can’t think of something super obvious. We haven’t seen just occasional issues on this, they usually have a cause.

One very common pitfall is that people forget to add an EventSystem in the scene, that disables the UI and makes it unresponsive. I don’t think it’s your case, but could it be that occasionally the EventSystem fails to initialise?

But from that screenshot, I see you have no Worlds either. So the Connect button is disabled because of that, and the Refresh button is disabled usually when the UI is trying to connect and hasn’t received response, yet. Then it enables allowing you to retry.

Ah, one thought: do you have Enter Play Mode Options on? If so, that might be the cause.
We are not fully compatible with it in coherence 0.10 series, so sometimes it can cause the UI not to find worlds. If it’s on, then try one thing: when the issue happens, try changing a script and triggering a recompilation, instead of restarting Unity.

If the UI starts working again, then it’s definitely that.

(PS: the good news is that we are fully compatible with that option in coherence 1.0, due end of this month)

Indeed… that was it… “Enter play mode options” was set…

Screenshot 2023-06-28 203714

Unsetting fixes the issue. Many thanks.

1 Like

Honestly… I would even leave it on. It’s such a time saver when you enter play mode often.

At least now you know what’s happening. If it breaks, you can always reimport a script or make a change and let it recompile.

And again, soon you’ll be able to use it again! Not so long until 1.0.