Using Visual Studio debugger should be supported

If trying to use Debugger in Visual Studio, the connection will die and create errors if staying at a breakpoint for more than a few seconds. It seems like there is some built-in keep-alive system for the connection, but ideally there would be an option to disable this in development.

1 Like

If you go inside Unity’s Project Settings > Player > Resolution and Presentation, do you have Run in Background enabled?

Also check Project Settings > coherence > Keep connection alive (Editor only)

Does it still happen then?

I had the “Run In Background” option already enabled. I did enable the “Keep connection alive” setting after reading this, but it did not seem to resolve the issue.

I put a breakpoint in my sim script when it gains authority, just for testing, and left it at the breakpoint for 1minute, then continued. After that, I encountered the highlighted errors and connection was lost: Movavi Cloud

1 Like

Interesting. And just as a final thing, the Room was still there?
In the Dashboard, you can choose a timeout for your Rooms to close them after inactivity. Is it set very low?
The URL:[your-org]/[your-project]/rooms

EDIT: nevermind, sorry, I saw that you mentioned in another thread that local Rooms stay active for up to 10 minutes. Looks like something we need to look at, thanks for the reminder!