Simulator Server "stuck" on Status : pending

I’ve been testing a Simulator locally, and got it to a milestone I was working towards. I went through the process of uploading schema, and simulator.

Attempting to start the world, and simulator I’m at a stuck state. I tried to restart it all from the dashboard, as well as delete, and recreate it. Neither of these appear to be working.

Hey @Marvin_Sorensen , do you have any error messages to share? Maybe a screenshot or two?

It’s not generating any logs in the dashboard to share. The simulator says pending, and then eventually the RS stops running. I will try to build/upload again, and see if there are any new results.

I was hoping that on the back end there would be something helpful thay customers can’t see.

After attempting to start a new world the logs from the RS show the following:

2023-07-25T 13:21:47-07:00Z {"cid":1,"dbgStream":0,"info":"[cinfo RoomUID: 0, SchemaID: 926ec68ee5dc2dd435feafc5cb5845aa10cf2ee2, AuthToken: eyJhbGci..., RoomSecret: false, IsSimulator: false, InitialScene: 0 ]","level":"info","logger":"netMgr","message":"new connection","playerID":"2f504e68155d454bb485b0317f75916c","project-id":"coherence","room":"room_0","time":"2023-07-25T20:21:45.3860Z","total":1}

Could it possibly be: IsSimulator: false?

When testing locally it usually will show:

2023-07-25T20:26:48.3015Z INFO : netMgr: new connection                                          project-id='local' cid=1 playerID='23586a23dcac4aacb14412cc903cb44f' room='room_0' dbgStream=0 info='[cinfo RoomUID: 0, SchemaID: 926ec68ee5dc2dd435feafc5cb5845aa10cf2ee2, AuthToken: eyJ0eXAi..., RoomSecret: false, IsSimulator: true, InitialScene: 0 ]' total=1
2023-07-25T20:26:48.3021Z INFO : briskServerConn: accepted connection                            cid=1 project-id='local' response='[ConnectResponse Conn 1393780670 UpdateFreq 60]'
1 Like

Thanks for the info, I’ll ask someone to come and take a look!

Sorry to hear you’re having problems, Marvin. Can you also tell us the Project ID? So our online team can look into the specific project’s state? It’s the one here:

Project ID: cijssh64h3r1k70qnse0
1 Like

I’m not sure if there were any changes on Coherence side? But I’ve tried some new builds of the simulator, and they are working!

Sometimes there can be temporary issues, and we’re monitoring the status of the online systems all the time and fixing whatever goes awry (it’s a long tech stack!), so that might have been the case. Glad to hear it’s all working now!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.